Commit 1cb8e4f3 authored by Michael Kuron's avatar Michael Kuron
Browse files

downgrade requirement to numpy 1.7

parent 21408a51
Pipeline #29920 failed with stage
in 6 minutes and 33 seconds
......@@ -103,8 +103,10 @@ ubuntu:
variables:
- $ENABLE_NIGHTLY_BUILDS
image: i10git.cs.fau.de:5005/pycodegen/pycodegen/ubuntu
before_script:
- apt-get -y remove python3-sympy python3-numpy
- ln -s /usr/include/locale.h /usr/include/xlocale.h
script:
- apt-get -y remove python3-sympy
- export NUM_CORES=$(nproc --all)
- pip3 install `grep -Eo 'sympy[>=]+[0-9\.]+' setup.py | sed 's/>/=/g'`
- pip3 install `grep -Eo 'numpy[>=]+[0-9\.]+' setup.py | sed 's/>/=/g'`
......
......@@ -85,7 +85,7 @@ setuptools.setup(name='pystencils',
author_email='martin.bauer@fau.de',
url='https://i10git.cs.fau.de/pycodegen/pystencils/',
packages=['pystencils'] + ['pystencils.' + s for s in setuptools.find_packages('pystencils')],
install_requires=['sympy>=1.2', 'numpy>=1.13.0', 'appdirs', 'joblib'],
install_requires=['sympy>=1.2', 'numpy>=1.7.0', 'appdirs', 'joblib'],
package_data={'pystencils': ['include/*.h',
'backends/cuda_known_functions.txt',
'backends/opencl1.1_known_functions.txt',
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment