Commit e603efb9 authored by Jan Hönig's avatar Jan Hönig
Browse files

Increasing the minimal python version

parent 4fecf0c5
......@@ -14,7 +14,7 @@
name: pystencils
dependencies:
# Basic dependencies:
- python >= 3.6
- python >= 3.8
- numpy
- sympy >= 1.1
- appdirs # to find default cache directory on each platform
......
......@@ -51,7 +51,7 @@ nbsphinx_execute = 'never'
nbsphinx_codecell_lexer = 'python3'
# Example configuration for intersphinx: refer to the Python standard library.
intersphinx_mapping = {'python': ('https://docs.python.org/3.6', None),
intersphinx_mapping = {'python': ('https://docs.python.org/3.8', None),
'numpy': ('https://docs.scipy.org/doc/numpy/', None),
'matplotlib': ('https://matplotlib.org/', None),
'sympy': ('https://docs.sympy.org/latest/', None),
......
......@@ -134,6 +134,6 @@ setuptools.setup(name='pystencils',
'ipython',
'randomgen>=1.18'],
python_requires=">=3.6",
python_requires=">=3.8",
cmdclass=get_cmdclass()
)
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment